Monday, May 26, 2008

How to use Canon MP210 on Ubuntu 8.04 (Linux printer drivers setup tutorial)

This is how to get your MP210 printer to work on Ubuntu 8.04:

Step1: Get the drivers.

You will need 4 driver packages:
* cnijfilter-common_2.80-1_i386.deb
* cnijfilter-mp210series_2.80-1_i386.deb
* scangearmp-common_1.10-1_i386.deb
* scangearmp-mp210series_1.10-1_i386.deb

Get them from here:
http://support-au.canon.com.au/EN/search?v%3aproject=ABS-EN&binning-state=model%3d%3dPIXMA%20MP210%0Amenu%3d%3dDownload%0Aos%3d%3dLinux&


Step 2: Install the drivers

prompt%> sudo dpkg -i cnijfilter-common_2.80-1_i386.deb cnijfilter-mp210series_2.80-1_i386.deb
prompt%> sudo dpkg -i scangearmp-common_1.10-1_i386.deb scangearmp-mp210series_1.10-1_i386.deb


Step3: Add the printer (if not already added)

* System->Administration->Printing
* Remove MP210_series
* Add new printer
** Device URI hal:///org/freedesktop/Hal/devices/usb_device_4a9_1721_505BD0_if1_printer_noserial

Or do it via CUPS:
http://localhost:631/printers/

If you just need the printer, you're done!


Step4: Download drivers for scanner, Extract & Build
http://internap.dl.sourceforge.net/sourceforge/mp610linux/mp150-0.14.2u.tar.bz2
prompt%> tar jxvf mp150-0.14.2u.tar.bz2
prompt%> cd mp150-0.14.2u
prompt%> make
prompt%> sudo make install

Step5: Setup XSane
prompt%> sudo mv /usr/lib/sane/libsane-pixma.so.1.0.19 /usr/lib/sane/libsane-
pixma.so.1.0.19.old
prompt%> sudo cp libsane-pixma.so /usr/lib/sane/libsane-pixma.so.1.0.19
prompt%> sudo apt-get install xsane

Step6: Run XSane
Click Applications->Graphics->XSane Image Scanner and scan away.


Enjoy!

References:
link1

6 comments:

Johannes Eva said...

Great! Just tried the scanner part, it works perfectrly :)
Thanks a lot.

(For the printer part, I just use the default MP180 Drivers under Ubuntu, it works well.)

petryxa said...

thanks!!!
it works!
danke schon! spasibo!

Helder Binimelis said...

gracias, me imprime pero el escaner no me funciona, ya veré como lo soluciono.

fab said...

Great guid! Worked without any problems.
Thanks a lot!

Hint: if you have a amd64 system and dpkg prints out
"package architecture (i386) does not match system (amd64)", just use
"--force-architecture".
Works very well.

Nice greetings from germany,

fab

binger said...

I can't get a 4x6 photo to print correctly, it is always centered to 8.5x11 or shrunk, or disoriented off the side. Anyone having these issues?

fab said...

there is another hint i found here:
http://ubuntu-utah.ubuntuforums.org/showthread.php?t=556980&page=3

the file scangearmp-mp210series_1.10-1_i386.deb is is labeled as IJ Printer Driver Ver. 2.80 for Linux(debian Package for MP210series)